DJI Osmo Plus Problem Solved

DJI Osmo Plus Connection Issues Using Google Pixel XL 2

I am quite used t DJI Android connection issues with Android. I own a couple different drones and the DJI and Android usability can be a little off-putting. However, nonetheless, it has not scared me away and I bought a DJI Osmo Plus a couple weeks ago. I have been playing with it quite a bit and ran into some unique issues I thought I would share. I toyed with just using my Pixel XL 2 as a camera on the Osmo Mobile 2. However, I decided the issues of balancing a larger phone may be more than I wanted to hassle with. I also looked at the standard DJI Osmo as it is pretty much the same basic camera for less money. However the regular OSMO has no optical zoom and I felt the optical zoom was worth a bit more money. So I went for the OSMO plus and I am pretty happy after a bit of a learning curve.

Setting Up the Osmo Plus for First Use

Unboxing the unit was straight forward and there was very little setup. I simply pulled it out and charged the battery as it has 0 charge out of the box. After a little less than two hours to charge, I finally got to play around with my new toy.

My first issue was, once charged the gimbal did nothing. I soon realized my issue. First of all, syncing the Osmo to your cell phone greatly depends on the phone itself. As mentioned, I have a Google Pixel XL 2 and it is running Android 9.0 Pie. This is fairly problematic and unreliable for a couple reasons which I will get into more in a bit. The thing I want to make clear is that you must sync you phone to the Osmo before it will work. This is a critical step in the process and caused me some confusion and concern out of the gate. For some reason, DJI has decided that the gimbal will not function until after the first sync occurs. So, when you start it up and the gimbal does nothing, do not panic.

Getting the unit to sync up was cumbersome. It must be synced to the phone via wifi first. This is done by turning on the power and then looking at your phone wifi settings. Once you see an OSMO wifi link available, click it and enter the standard password, 12341234. Once you have that set, you open the DJI Go app. To be clear, do not try to use the DJI Go 4 app, it will not work.

Once you have the app open, it will likely prompt you to update flight maps. This happens because this is the same app for the Inspire 1 and I believe also the Phantom 3. I had some struggles with this. I tried to cancel and the OSMO would not connect. I found on my Pixel XL 2 that I had to at least try and fail to update the maps and let it fail. Because there is no wifi, the flight maps will not update anyway (and you do not need them for an OSMO). However, it will keep trying and timeout. Once this happens it will kick you back to the app. It should automatically prompt you to connect to the OSMO. To be clear, this took a good 20 minutes of going back and forth, restarting the app, the phone and even uninstalling and re-installing. I believe you may experience the same issues so be aware that you just need to be persistent until the app finds your OSMO for the first time.

Once it is found, the app will tell you that you need an internet connection. Disconnect the OSMO wifi and connect regular wifi and proceed with the prompts. The DJI app will make you log into your DJI account and then will serve you up a code that is intended to be loaded to the OSMO. Once you have the code, you go back to the OSMO wifi and turn it back on. This should load the code to your OSMO. I am not sure this is the standard process at all, I am telling you what my Pixel XL 2 forced me to do. Once I did all this, the gimbal came to life and I was connected to the DJI Go App.

The next thing I did was turn off the OSMO and left the app open. I turned it back on and the app relinked just fine. Then, I placed the phone in the holder on the OSMO and that is when I started experiencing more issues. I fought for 3 days trying to figure out my intermittent connection issues. I finally realized that when the phone is on the holder it was intermittent, but when in my hands it worked fine most of the time. I finally came to the conclusion that it is due to the squeeze function on the sides of the phone that turn on Google assistant. Even handling the phone, it is easy to squeeze the sides. The app seems to stop the google assistant from opening, but I believe it is running in the background and interfering with the OSMO connection. In other occasions, I have had the camera connect and only got a grey and or a black screen. I could control the camera with the phone but no image appears.

My solution is two fairly simple steps that are so far reliable. First of all, do not squeeze the lower half of the phone when installing the phone on the holder. You can also disable the squeeze function but it is not necessary to do so in my experience. The second step is to pull the swinging phone holder clip to the end of the phone rather than the corners. Any overlap over the sides may initiate the squeeze function and cause the issue which will drive you mad. I have included a video that shows a little more about this and also helps show what I am talking about.

I hope this helps, more tips to come! If you like this article and found it useful please subscribe to my blog and Youtube channel.

Leave a Reply